Nissan Altima - Car only starts in neutral

Nissan Altima 2.5 S, year 2005 with original miles of 47,000. Car will not start in park. It only starts in neutral. Anyone know what the problem is?

  1. You will see these arrows in every question page. They allow you to upvote/downvote according to the relevancy of the question/answer.
  2. Edit your question/answer if you wish to change it or update it.
  3. If you dont understand something about the question, leave a comment asking. The answer field should be only used for answers.
  4. If the author of a question marks an answer as the solution, this mark will be visible.
  5. Click here to see more details about the operation of the system!

2 answers

  • The problem is with the neutral safety switch. This video will show you how to test: https://www.youtube.com/watch?v=r8QJX-MWkBU

    Note that the switch may not have failed but only needs an adjustment. If the switch is bad, replacement part is $77. Easy job to DIY, but if you're having it done it should not be more than an hour's labor.

  • The problem is definitely the neutral safety switch,

    If you go to a repair shop it could cost upwards of $170 but if you're the DIY kinda person like me then its only the cost of the part which for your car should only be about $50-$70.

    I read a really good article that monster transmission posted the facebook

    Monster goes over the whole DIY Neutral safety Switch Replacement Process, how to test it, symptoms of a failing one and a lot more.

    Hope this helps! :)

Use one of the following services to sign in or sign up and contribute to this question.

Not the answer you were looking for?
Search other questions with the tags Nissan Altima 2005 2005 Nissan Altima or ask a question